Appendix A: Presentation Slides

The following section includes the complete set of slides that are used in the instructor-led training.

The presentation slides are added to this Laboratory Workbook for your convenience and for reference.
Ultiboard™ Basics
PCB Layout

1 Day Hands-On
Training Seminar
What you need to get started

NI Ultiboard 10 Power Pro

File locations

- C:\Exercises\Ultiboard\
Getting the most out of this course

- Experiment with hands-on exercises
- Do your best to finish all exercises
- If time permits, experiment different scenarios
- Ask questions
  
- Please switch your cell phone to vibrator mode

This course is not design nor intended for:

- Teaching Electronics/PCB design theory
- Develop a PCB project for any student in the class
Course Goals

At the end of this course you will:

- Understand the features of the Ultiboard user interface
- Apply efficient part placement procedures
- Apply efficient trace placement procedures
- Create custom footprints (landpatterns)
- Work with copper area and design constraints
- Prepare your design for manufacturing

Introduction

TOPICS

- Ultiboard
- Design Flow
- Ultiboard GUI
- Environment Preferences

Note: Screen captures included in this presentation use a color scheme that is printer-friendly for grayscale. It may differ from the default- or user-configured color scheme in Ultiboard.
What is Ultiboard?

- PCB Layout software
- Integrated Platform with NI Multisim
  - Transfer
  - Forward and Back Annotation
- Autoplacer and Autorouter
- Industry-standard file export
- Gerber Viewer and board 3D View

The Design Process
Where does Ultiboard fit in the design flow?

NI Multisim  NI Ultiboard  LabVIEW
Part Selection  Capture & Simulation  Layout  Verification
Benefits of Integrated Platform

- Directly transfer designs from Multisim to Ultiboard
- Keep designs up-to-date with forward and back annotation
- Find a component in the Multisim schematic and vice versa

The Ultiboard GUI

- Organized menus
- Quick access toolbars
- Design Toolbox
- Spreadsheet View
- Resizable Workspace
- Frames allow:
  - Move
  - Hide/unhide
  - Resize
Global Preferences

- Options » Global Preferences
- General Ultiboard environment options:
  
  **General Settings** General workspace options, mouse-wheel behavior, undo options, view options, crosshair options
  
  **Paths** Set paths for configuration files, default paths and database paths
  
  **Colors** Set up color schemes for the Ultiboard workspace
  
  **PCB Design** General options for PCB design actions such as DRC, trace placement/deletion, router, component drag, and so on
  
  **Dimensions** Dimension lines setup
  
  **3D Options** 3D View settings

---

PCB Properties

- Options » PCB Properties
- PCB-specific options:
  
  **Attributes** Displays attributes associated with the PCB
  
  **Grids & Units** Set design units and grid spacing
  
  **Copper Layers** PCB layer technology parameters
  
  **Pads / Vias** Default settings for pads and vias
  
  **General Layers** Add/remove layers from design, rename layers
  
  **Design Rules** DRC parameters
  
  **3D Data** This tab has no use in PCB Properties
  
  **Favorite Layers** Set layer shortcuts
Toolbars and menus

- View » Toolbars » ...
- Organized based in functionality
- All toolbar functions found in menus
- Right-click toolbar area and toggle toolbars
- Customizable (functions, location)
- ToolTips

Click this section of the toolbar and drag to relocate.

Customize the environment

- Options » Customize User Interface
- Add/remove functions in toolbars and menus
- Create new menus and toolbars
- Set shortcut keys
- Display properties for toolbars and menus
Design Toolbox

- Project hierarchy view
- Add / edit / remove / rename designs in the current Project
- Set active layer
- Dim / hide / unhide layers

Spreadsheet View

- Complete design summary
- Find and select components / nets
- Modify virtually any property from components, nets, pads, vias and copper areas
Spreadsheet View  Toolbar

- Toolbar lets you quickly:
  - Export
  - Sort
  - Find
  - Lock / Unlock
  - Preview

Selection Toolbar

- Edit » Selection Filter » Enable selecting ...
- Defines exactly what the mouse pointer and selection rectangles are allowed to select
Workspace Area

- Use the mouse-wheel to zoom in and out
- Resizable
- Multiple tabs per design
- Ruler bars located in top and left margins
- Dim or hide layers not in use for better visibility

Lesson 1
Transfer & Board Design Setup

TOPICS
- Transfer from Multisim to Ultiboard
- Board Outline and Setup
Transfer from Multisim

- In Multisim select Transfer » Transfer to Ultiboard 10
- Virtual Components and non-active variants are not transferred
- Ultiboard prompts for default track width and clearances
- Import Netlist Actions are displayed

![Multisim dialog box](image)

Transfer from Multisim - Virtual Components

- From Multisim, you may receive a message warning you about virtual components in your schematic

![Message dialog box](image)

- In most cases, it refers to power supplies and ground references
- You have to make sure your board is correctly prepared for transfer
Transfer from Multisim - Virtual Components

- Generate a Bill of Materials report
  - Reports » Bill of Materials
  - Click the Show Virtual Components button
- Review which components are marked as virtual

- If actual parts are marked as virtual go back to the schematic and assign footprints to them

Transfer from Multisim - Virtual Components

- For power supplies and ground references a good practice is to place connectors

```
J1
Post15
Ground
Neg15
Input
Output
HDR1X6
```
Board Technology

- Options » PCB Properties
- Copper Layers tab
- Set number of layers
- Layer pairs
- Via Support
- Board clearance
- You can save the current technology for later use
  - File » Save Technology

Board Technology

- Units supported
  - Metric
  - Imperial
- 1 nm internal resolution
Via Support

- Normal through-hole via
- Blind vias
- Buried via

Cross section of a multi-layer PCB

Layer Technology

1. Single Sided
2. Double Sided
3. Multi-layer with double sided boards (layer pairs)
4. Multi-layer with double sided boards and single layer stack-ups

Board core (fiberglass/resin)  Laminated copper foils
Board Outline

- Default outline is placed after transfer
- Create a new outline:
  - Manually
    - Set Board Outline layer active
    - Delete current outline
    - Draw a new one
    - Any shape
  - Board Wizard
    - Rectangular and circular
  - Import DXF
    - Any shape

Board Wizard  Step 1

- Tools » Board Wizard
- Step 1: Set layer technology
Board Wizard  □  Step 2

- Step 2: Set board layers and via support

Board Wizard - Board Layers

- Step 3: Set shape of board
  - Rectangular
  - Circular
Lab 1: Transfer and Board Design Setup

Laboratory Workbook
Page 1
30 minutes

- Transfer a design from Multisim to Ultiboard
- Setup a project file for your board layout
- Experiment with Board Outlines

Lesson 2
Parts & Placement

TOPICS
- Parts placement
- Footprint Editor
- Component Wizard
Part Placement

- Methods:
  - Manual Placement
    - Drag and place Workspace area components
    - Drag and place Spreadsheet View components
  - Part Sequencer
  - Autoplacer
- If you need to add parts, Place » From Database

<table>
<thead>
<tr>
<th>Ref.</th>
<th>Value</th>
<th>Object</th>
<th>Status</th>
<th>Price</th>
<th>Serial Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>U16</td>
<td>7485N</td>
<td>DSP14300</td>
<td>No</td>
<td>15.0000</td>
<td></td>
</tr>
<tr>
<td>U15</td>
<td>14855CM</td>
<td>SUR10110049...</td>
<td>No</td>
<td>15.0000</td>
<td></td>
</tr>
<tr>
<td>U14</td>
<td>148539R</td>
<td>ORP000</td>
<td>No</td>
<td>15.0000</td>
<td></td>
</tr>
<tr>
<td>U13</td>
<td>HR0414</td>
<td>ORP000</td>
<td>No</td>
<td>0.0000</td>
<td></td>
</tr>
<tr>
<td>U12</td>
<td>HR0413B</td>
<td>QM2120</td>
<td>No</td>
<td>15.0000</td>
<td></td>
</tr>
</tbody>
</table>

- Placed parts will have a bright green circle in the Spreadsheet View

- Tools to assist you:
  - Part Shoving
  - Align / Space functions
  - Flip / Swap functions
  - Lock / Unlock
  - Ruler Bars
Part Placement  -  Manual Method

- Set selection filter to **Enable selecting Parts**
- Click component in Workspace and drag to new location
- Click component in Spreadsheet View and drag to new location
- Use * to set accurate position

Part Placement  -  Part Sequencer

- Access from the Spreadsheet View toolbar
- Select first component then click **Part Sequencer**
- Place component then next unplaced component in list will get attached to the mouse pointer for you to place
- Press `<ESC>` to exit placing mode

© National Instruments Corporation  http://www.ni.com/ultiboard
Part Placement - Autoplacer

- Select Autoroute » Start Autoplacement
- Lock components that are already placed and you do not want to move
- Locked components have an orange boundary around them
- To lock, Edit » Lock

Keep-in / Keep-out Areas

- Restrict components or nets to be placed within an specified area
- Use the Group Editor and configure Part Groups or Net Groups to assign them to the area
- Select keep-out or keep-in
- Place » Keep-in/Keep-out Area
  - Draw shape to be assigned
Footprints

- Footprints are the shapes (or landpatterns) that graphically represent each component in the layout
- Manufacturer's datasheets will commonly have footprint information
- In Ultiboard you can:
  - Edit footprints
  - Create new footprints
- Footprints are organized in the Master, Corporate and User database
- Vast collection of THT and SMT footprints

Footprint Properties

- Access properties:
  - Select component, then Edit » Properties
  - Double-click component
  - Right-click and select Properties
- Edit attributes, position, 3D data and component spacing parameters
In-Place Part Edit

- Modify the shape of footprints in the Footprint Editor mode
- You can modify footprints already placed in the layout
  - Select component then:
    - Right click and select **In-Place Part Edit**
    - **Edit > In-Place Part Edit**
- Use layers, drawing tools and selection filter to modify footprint
- Apply changes immediately on the layout, or save the modified component to database

Database Manager

- **Tools > Database > Database Manager**
- Organize, edit, delete, create footprints
Footprint Creation

- Two methods to create a new footprint
  - Database Manager
    - Click New in the Parts list
    - Create footprint in the Footprint Editor
    - Use layers, drawing tools and selection filter to modify footprint
  - Component Wizard
    - Tools → Component Wizard
    - Step by step guide
    - Only for IC packages

The Component Wizard

- Steps you through the process of creating a new component
- Only supports IC-like packages
- Save new component to Corporate or User database
- Seven-step process
- Dimensions can be found in datasheets
The Component Wizard  ▶  Step 1

- Step 1: Select Technology
- THT or SMT

The Component Wizard  ▶  Step 2

- Step 2: Package Type
- Select from available package types
- Preview available
- If the package you are looking is not available, select next closest, you can always edit a footprint at a later time
The Component Wizard  Step 3

- Step 3: Package Dimensions
- Reference the component's datasheet

The Component Wizard  Step 4

- Step 4: 3D Color Settings
- Change 3D environment colors
The Component Wizard  Step 5

- Step 5: Pad Type and Dimensions
- Use dimensional drawings or set depending on a design requirement

The Component Wizard  Step 6

- Step 6: Pins
- Specify number of pins and distance between centers
The Component Wizard \[\rightarrow\] Step 7

- Step 7: Pad Numbering
- Set pad numbering and direction

The Component Wizard \[\rightarrow\] Finish

- File » Save to Database
- Save to Corporate or User database
- Add attributes or make any pending modification
Lab 2: Place, Edit and Create Components

Laboratory Workbook
Page 15
30 minutes

- Place Parts into the board outline
- Modify footprints with the Footprint Editor
- Create a custom footprint

Lesson 3
Design Setup Before Routing

TOPICS
- Netlist Editor
- Forward and Back annotation
- Pin and Gate Swap
- Trace Settings and Clearances
- Renumber RefDes
Netlist Editor

- Tools » Netlist Editor
- Net-related tasks:
  - Add / Remove / Rename
  - Set routing layers for each layer
  - Assign Bus groups
  - Modify Pin assignments

Forward and Back Annotation

- Done from Multisim
- Transfer » Forward Annotate to Ultiboard
  - Creates a new netlist
  - Ultiboard applies changes that are different from current layout
- Transfer » Backannotate from Ultiboard
  - Log (.log) file created on every change in Ultiboard
  - Backannotate ideal for:
    - RefDes changes
    - Deleting components
Forward and Back Annotation

- Backannotate limitations:
  - Adding new components in Ultiboard
  - Changing netlist information in Ultiboard
- Forward Annotation is more recommended
  - All actions are supported

⚠️ Caution: Undo actions in Ultiboard create ‘tasks to be performed’ in Multisim.
⚠️ Caution: After backannotate process is done, the log file is erased.

Pin and Gate Swap

- Enables to user to swap pins or gates from specific ICs
- Pin and Gate Swap must first be enabled in Multisim before transferring the design to Ultiboard
- Enabled in the Spreadsheet View » Components tab
  - Pin Swapping column
  - Gate Swapping column
Pin and Gate Swap

- Allows for more efficient routing and better use of gates or pins
- Design » Swap Pins
- Design » Swap Gates

---

Trace Settings

- Change trace widths before routing
- Use the Spreadsheet View (instead of the Netlist Editor)
  - Use <SHIFT> or <CTRL> for multiple selection
  - Trace Width column
Clearance Setup

- Change clearances before routing
- Useful for Design Rules Check (DRC)
- View » Clearances

Renumber RefDes

- Tools » Renumber Footprints
- Easier to locate components
  - Example, technician looking for a damaged part
- Organized in a logical direction
  - Example, left-to-right, top-to-bottom
Lab 3: Board Setup before Routing

Laboratory Workbook
Page 37
30 minutes

- Change the netlist
- Make design changes and synchronize with Multisim
- Swap pins and gates
- Setup trace settings and clearances

Lesson 4
Traces and Copper Areas

TOPICS
- Routing methods
- Autorouter
- Powerplanes and Copper Areas
Routing Copper Traces

- 4 methods:
  - Connection Machine
  - Follow-me Router
  - Manual Routing
  - Autorouter
- Tracing features:
  - Start on ratsnest
  - Snap to pad
  - Rubber banding

Routing Copper Traces

- Select active layer in the Design Toolbox
  - Except in Autorouter
- Configure Routing Layers where Nets are allowed to be routed
  - Spreadsheet View, Nets tab
  - Routing Layers column
The Connection Machine

- Click the ratsnest connecting the two pins you want to trace
- Ultiboard provides the **complete** route for you
- Move mouse to change layout of route
- Click to set the trace

Follow-me Router

- Click the ratsnest connecting the two pins you want to trace
- Ultiboard provides the **suggested** route for you
- Completed trace follows the mouse pointer
- Move mouse to change suggested route
- Click to set a vertex (turn)
- Click end pad to finish
Manual Routing

- This option provides **complete** control of the trace position
- Click start pad
- Move mouse to create trace
- Click to set a vertex (turn)
- Click end pad
  - End pad has a crosshair mark to identify it

Place Vias while tracing

- While routing a trace, change the layer from the **Layers** list in the toolbar, this creates a via
Change Trace Width while tracing

- While routing a trace, change the width from the Trace Width list in the toolbar, this changes the thickness of the trace.

- Right-click menu:
  - Narrow
  - Widen
  - Good option for tight spaces

Autorouter

- Advanced routing algorithms
- Lock nets already placed
- Configure routing layers
- **Autoroute**
  - Start / resume Autorouter
- Review **Results** tab in the Spreadsheet View
Autorouter Options

- Configure options before routing
- **Autoroute**
- **Autoroute / place Options**
- Options include:
  - Cost Factors
  - Rip-up cycles
  - Optimization
  - Bus routing

Autorouter Tips

- If Autorouter is not able to route 100% of the board:
  - Modify Autorouter options
  - Increase number of vias permitted
  - Decrease clearances
  - Decrease trace width
  - Increase number of layers
  - Add jumpers
    - Place » Jumper
- After Autorouter is done, review traces and make any necessary change in geometry or position
Moving and deleting traces

- You can move and delete traces
  - Select trace and press <Delete>
  - Select trace, drag and move with the mouse pointer

- Delete copper using Edit » Copper Delete » ...

Powerplanes and Copper Areas

- Place » Powerplane
  - Complete layer filled with copper
  - Mostly used for ground and power
  - Assign to any net

- Place » Copper Area
  - Special shapes filled with copper
  - Mostly used for:
    - Power and ground signals
    - Heat dissipation
    - Noise reduction
**Thermal Relief**

- A thermal relief is added to every pin connection assigned to the same net as the copper area or powerplane.
- You can change the shape of the thermal relief in the properties of:
  - Pin
  - Copper area
  - Powerplane
  - PCB Properties
  - Spreadsheet View
- Shapes available:
  - X
  - +
  - -
  - |  

**Polygon Splitter**

- Design » Polygon Splitter
- Split any powerplane, copper area or polygon shape
- Draw a line across the split section
Net Bridges

- When you need to join to copper areas (or powerplanes)
  - Example, analog ground with digital ground
- Place » Net Bridge
- Select a net bridge from the database
- Assign layers to each side of net bridge

Fill Style

- Change the fill pattern used in copper areas or powerplanes
- Many options available: [patterns]
- Access from the properties of the copper area or powerplane
- Pattern change affects electrical characteristics
Lab 4: Working with Traces and Copper Areas

Laboratory Workbook
Page 49
30 minutes

- Route the design
- Use all methods for routing
- Create Powerplanes and Copper Areas

Lesson 5
Preparing for Manufacture

TOPICS
- Board design improvement tools
- Design Rules Check (DRC)
- Preparing the board for manufacturing
- Export files for manufacturing
- Gerber and 3D Viewers
Corner Mitering

- Reduce or remove sharp angles
- Creates 135° angles
- Define maximum angle to check and change
- Better for manufacturing
- Design » Corner Mitering

Tear Dropping

- Typically used with very small-sized traces
- Prevents breakage in the copper between the trace and the pad
- Adds a flair to the connection between the trace and pad
- Design » Add teardrops
Design Rules Check (DRC)

- Checks the board's integrity for components overlapping, incorrect layer placement and routing, clearances, untraced pins and so on
- Results in the DRC tab of the Spreadsheet View
- Design » Netlist and DRC Check
- Double-click error to go to error location

Caution: DRC is a critical step before exporting Gerber files, always use this feature.

Design Rules Check (DRC) Fix

- Most common error is a clearance error
- Select View » Clearances
- Fix the error by moving the trace
Connectivity Check

- Similar to DRC
- Checks integrity of pin connections on the selected net
- Design » Connectivity Check
- Results displayed in the Results tab of the Spreadsheet View
Import DXF Files

- Import logos, text, any drawing in 2D DXF format
- Merge into existing layers
- File » Import » DXF

⚠ Caution: Set the Units correctly, otherwise the size and shape of the imported object will be wrong.

Mounting Holes

- Add mounting holes to your PCB
- No need to use the database
- Place » Hole
Dimensions

- Select any of the Mechanical Layers
- Great for manufacturing drawings
- **Place » Dimension » ...**
- Options:
  - Standard
  - Horizontal
  - Vertical

Export

- **File » Export**
- Multisim exports many types of files
- Configure each export option with the **Properties** button
- Once configuration is done, click **Export** to generate output file
Gerber

- Industry standard Gerber export
- RS-274X generates aperture mapping file
- One gerber file per layer
- Option to:
  - Merge layers and create a composite file (multiple layers)
  - Negative image
  - Reflection image
  - Oversize soldermask or pastemask

⚠️ Caution: It is important to talk to your production house and identify all the files and formatting information they need to support their manufacturing process.
NC Drill

- Creates a drill file (.drl) and report file (.rep)
- Drill file is a gerber file with drill centers
- Report file indicates the size of each drill
- Configure units and precision

Parts Centroids

- Used for parts placement
- Information can be used in CNC and parts-insertion machines
Bill of Materials

- BOM helpful for manufacturing and planning

Gerber Viewer

- Ultiboard includes a built-in Gerber Viewer
- Review Gerber files before sending to manufacturing
- Use Design Toolbox to hide/unhide layers
- Every Gerber file opened is a separate layer
- File » Open
Print

- File » Print
- Useful for:
  - Documenting
  - Printer-based PCB processes
- Create negative images and reflections

3D View

- You can review your finished design in 3D
- Great for documents or presentations
- Use mouse buttons and wheel to:
  - Move
  - Pan
  - Zoom
- View » 3D preview
Lab 5: Preparing for Manufacture

Laboratory Workbook
Page 63
30 minutes

- Apply corner mitering and tear dropping
- Verify and correct DRC errors
- Generate Gerber files
- Use the Gerber Viewer
- Use the 3D View

Conclusion

TOPICS
- Technical Support
- Multisim Basics: Schematic Capture & Simulation
- Contact Information
Technical Support

ni.com/ultiboard
ni.com/support/ultiboardsupp
ni.com/ask

NI Circuit Design Suite
Technical Library

Multisim Basics:
Schematic Capture & Simulation

- 2-Day Hands-On Training
- Learn how to capture circuits and simulate
- Co-simulate with the MCU Module
- Learn how to use design variants
Contact Information

- Sales
  - NI EWB Group (Toronto)
  - 1.800.263.5552
- Customer Service
  - NI Corporate (Austin)
  - 1.800.433.3488